Bu konudaki kullanıcılar: 2 misafir, 1 mobil kullanıcı
2
Cevap
31
Tıklama
0
Öne Çıkarma
Excel Eşleştirme

A alican456 Konu Sahibi
3 yıl (253 mesaj)
Selam,

Sıkıntım görselde, çözümü bilen varsa canını yerim.
< Resime gitmek için tıklayın >




C cdemir
3 yıl (5144 mesaj)
Kod ve barkod sütunun yerini değiştirirseniz yada A sütununu C'ye kopyalarsanız Düşeyara formülü ile istediğinizi yapabilirsiniz.

Barkod verilerini C'ye kopyaladığınızı varsayarak formülü oluşturdum.
D2 hücresine yazıp aşağıya doğru kopyalayabilirsiniz.

=DÜŞEYARA(E2;B:C;2;0)

Bulamadığı kodlar için #YOK yazacaktır bunu engellemek için formülü bu şekilde yazabilirsiniz.

=EĞER(EYOKSA(DÜŞEYARA(E2;B:C;2;0));"";DÜŞEYARA(E2;B:C;2;0))


Basitçe Düşeyara hakkında bilgi vereyim.
=DÜŞEYARA(E2;B:C;2;0)

E2 bulunmasını istediğimiz değer
B:C ise verileri bulacağımız listenin adresi. (Bulacağımız veri listenin ilk sütununda olmalı. Aksi takdirde formül çalışmaz)
2 Eğer veri bulunursa listenin kaçıncı sütunundaki veriyi getireceğini belirtiyor. (Burda 2. sütundaki barkod verisini alacak)
0 Birebir aynı olan veriyi bulması için yazıyoruz. 1 yazarsak benzer bir değer bulup onunla ilgili sonucu getirir.

Kolay gelsin ;)





< Bu mesaj bu kişi tarafından değiştirildi cdemir -- 29 Mart 2018; 20:32:8 >
Bu mesaja 1 cevap geldi.

Bu mesajda bahsedilenler: @alican456

A alican456 Konu Sahibi
3 yıl (253 mesaj)
quote:

Orijinalden alıntı: cdemir

Kod ve barkod sütunun yerini değiştirirseniz yada A sütununu C'ye kopyalarsanız Düşeyara formülü ile istediğinizi yapabilirsiniz.

Barkod verilerini C'ye kopyaladığınızı varsayarak formülü oluşturdum.
D2 hücresine yazıp aşağıya doğru kopyalayabilirsiniz.

=DÜŞEYARA(E2;B:C;2;0)

Bulamadığı kodlar için #YOK yazacaktır bunu engellemek için formülü bu şekilde yazabilirsiniz.

=EĞER(EYOKSA(DÜŞEYARA(E2;B:C;2;0));"";DÜŞEYARA(E2;B:C;2;0))


Basitçe Düşeyara hakkında bilgi vereyim.
=DÜŞEYARA(E2;B:C;2;0)

E2 bulunmasını istediğimiz değer
B:C ise verileri bulacağımız listenin adresi. (Bulacağımız veri listenin ilk sütununda olmalı. Aksi takdirde formül çalışmaz)
2 Eğer veri bulunursa listenin kaçıncı sütunundaki veriyi getireceğini belirtiyor. (Burda 2. sütundaki barkod verisini alacak)
0 Birebir aynı olan veriyi bulması için yazıyoruz. 1 yazarsak benzer bir değer bulup onunla ilgili sonucu getirir.

Kolay gelsin ;)








saçımdan beyazlar eksildi uzaklar yakın oldu, ya senin kaşşığını kızlar yesin ya



DH Mobil uygulaması ile devam edin. Mobil tarayıcınız ile mümkün olanların yanı sıra, birçok yeni ve faydalı özelliğe erişin. Gizle ve güncelleme çıkana kadar tekrar gösterme.