Kullanıcı Adı:
Şifre:
Bu konudaki kullanıcılar: 1 misafir
1
Cevap
0
Tıklama
0
Öne Çıkarma
ÇOKLU DÜŞEY ARAMA

F
fatcot85
geçen ay (105 mesaj)
Merhaba Arkadaşlar,

Excel'de bir konu ile ilgili yardıma ihtiyacım var.

Aşağıdaki ekran görüntülerinde de görüleceği üzere excelin birinci sekmesinde proje kodu, tedarikçi ve alış tarihi gibi veriler olsun; ikinci sekmesinde de bunlara ilave olarak alım miktarları da yer alsın.

Tek bir veriye göre düşeyara uygulamasını biliyorum. Ancak benim öğrenmek istediğim çoklu veriye göre arama nasıl yapabiliriz. Örneğin alım miktarlarını 2. sekmeden 1. sekmeye almak istiyorum. Ancak hem proje koduna göre hem de alış tarihine göre aratarak iki veri de tutuyorsa bu alım miktarını 1. sekmedeki tabloya almak istiyorum. Bu konuda yardımcı olabilirseniz memnun olurum.

Bu excel tablosunu sadece örnek göstermek amacıyla yaptım.

< Resime gitmek için tıklayın >< Resime gitmek için tıklayın >




C
cdemir
geçen ay (4515 mesaj)
İkinci tabloda da yeni bir anahtar sütün oluşturarak, bu sütunları proje kodu ve alış tarihlerini birleştirip, bu sütüna göre düşeyara yapabilirsiniz.

İkinci tablonun sayfa2 de olduğunu varsayarsak.

Tabloyu bir sütun sağa kaydırın. A sütununa =B2&D2 formülünü yazıp alt satırlara uygulayın.

Sayfa1 D sütununa =DÜŞEYARA(A2&C2;Sayfa2!A:E;5;0) formulünü yazıp aşağıya doğru uygulayın.